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About Parabenôs iRecovery Stick 

 

Welcome to Parabenôs iRecovery Stick!  

 

This tool allows you to recover data from a variety of iPhone/iPad/iPod Touch devices. 

Recovery of live data on the device as well as recovery of deleted data such as text 
messages is part of the many features of this tool. The iRecovery Stick will work either 

directly with the device via a cable connection through a computer or the processing of a 
backup file from the computer associated with the device. 

 

All iPhone OS are supported including 1.x-11. 
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Whatôs New? 

¶ iOS 11 Support: Added support iOS 11. Must have the device password.  
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Getting Started 

System Requirements 

 

The following requirements must be met to use iRecovery Stick: 

¶ iRecovery Stick requires a Windows Vista or newer 32 or 64-bit operating system. 

¶ To use the Export to Microsoft Excel feature, Microsoft Excel must be installed on 
your computer and you must add the .Net Framework programming tools during 
the installation process.  

¶ To use the Tracking History feature, Google Earth should be installed on the 
computer. 

 

How to Use iRecovery Stick 

 

To start using the iRecovery Stick, do the following: 

 

1. Disable anti-virus software on computer. Occasionally the anti-virus software on a 
computer can interfere with the recovery that is done by the iRecovery Stick. It is 

recommended that you disable this software. 

2. Plug the iRecovery Stick into the USB port of your computer. 

3. Open the USB drive when you are prompted by Windows. 

4. Double-click the iRecoveryStick.exe file. 

5. If drivers for iPhone/iPad/iPod Touch are not installed, the iRecoveryStick.exe file 

will initialize their installation. Follow the installation wizard i f needed. 

6. When installation is finished, remove the iRecovery Stick from USB port and restart 
the computer. This will ensure all drivers are installed properly and are ready for 
your recovery.  

7. Ensure the anti-virus software is still disabled when the computer reboots so that 

it will not interfere with the recovery. 

8. Plug the iRecovery Stick into the USB port of your computer. 

9. Double-click the iRecoveryStick.exe file. 

10. The iRecovery application main window will open. 
11.  You now can select your device or load a backup file for recovery using your 

iRecovery Stick. 
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Application User Interface 

Understanding User Interface 

 

The iRecovery Stick interface includes the following parts: 

o The Main page: This page contains information about iRecovery Stick and three 

buttons that let you open the existing workspace, start recovery process from the 

iPhone/iPad/iPod Touch device or iTunes backup files.  

o The Data page: On this page, the recovered data and other backup data received 

from the device is displayed.  

o The Main menu: The menu provides access to the main functionality of Paraben's 

iRecovery Stick. 

 

Main Page 

 

The Main page of iRecovery Stick opens at the program start-up. 

 

It contains the following elements: 

o A tool bar. 

o Short description of iRecovery Stick. 

o Three icons: Start Recovery, Open Workspace, and Start Import from iTunes 
Backup.  

o A link to the Data page if there is any data in the workspace. 

 

From the Main page, you can do the following: 

o Start recovery process from the iPhone/iPad/iPod Touch device or iTunes backup 

files. 

o Define program options. 

o Open an existing workspace.  

o Move to the Data page. 

o Rename the currently opened workspace. 

o Export workspace data to Excel. 

 

Data Page 

 

The Data page opens when data recovery process finishes. This screen will also open 
when you open a workspace or you click the Back to Data link on the Main page.  

 

The Data page contains the following elements: 

o A list of data categories. 

o The Data pane in which data is displayed.  

o The name of the device from which data was recovered. 

o A Search field. 
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o The Details pane, including the Properties tab, the Bookmarks tab, the Search 

Results tab, the Extended View tab, and the Acquisition Details tab.  

o A link to the Main page. 

 

From the Data page, you can do the following: 

o View the recovered data. 

o View the properties of the device from which you recovered data. 

o Search text data in the workspace. 

o Create and access bookmarks. 

o Define program options. 

o Open an existing workspace. 

o Go to the Main page. 

o Save the open workspace using a different name. 

o Export workspace data to Excel.  

o Export location history. 
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Main Menu 

 

File Menu 

The File Menu contains basic file options for working with iRecovery Stick.  

Menu Item Description 

Open Workspace Opens a saved workspace. 

Save As Saves the open workspace under a different name. 

Start Recovery Closes the open workspace and displays a screen from 
which you can select a device to scan.   

Start Import Starts the import of iPhone backup files. 

Export to Microsoft Excel Exports workspace content as an MS Excel (.xls) file.  

Exit Shuts the iRecovery Stick down.  

 

 

View Menu 

The View menu lets you display tools in the iRecovery Stick user interface. 

Menu Item Description 

Properties Opens the Properties pane containing properties of the 
acquired device.  

Bookmarks Opens the Bookmarks pane containing created bookmarks. 

Acquisition Details Opens the Acquisition Details pane containing information on 
device acquisition.  

Extended View Opens the Extended View pane for viewing advanced 
information on recovered data and some application data (e-

mails, etc.) 

Search Results Opens the Search results pane containing results of the 
recent search.    

 

Tools Menu  

The Tools menu lets you check for iRecovery Stick updates and define logging and 

folder options. 

Menu Item Description 

Options Allows you to define logging options and the default folder for saved 

workspaces. 

Validate 

Workspace 

Runs a hash encryption algorithm on a workspace data to ensure 

the data has not been altered if the data is being used as evidence. 

Check for 
Updates 

Connects to the Parabenôs site to download updates.   

 

 

Help Menu 

The Help menu gives access to this help file, information about the iRecovery Stick 
application, and displays registration data. 
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Menu Item Description 

Help Opens iRecovery Stick user documentation. 

About Qt Provides data about the Qt tool, licensed for use in iRecovery Stick. 

About Displays the iRecovery Stick description and the version number. 
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Recovering Data 

About Data Recovery 

iRecovery Stick allows you to recover data either from an iPhone/iPad/iPod Touch device 

or from an iPhone backup.  

 
CAUTION: iRecovery Stick places recovered data in a temporary workspace that is automatically 

created in the workspace folder. The folder location is defined in the Options menu and has a 
Workspace<number>.ds name. When you close the workspace, you must save it or you will lose 
the data.  

 

Recovering Data from iPhone/iPad/iPod Touch Device 

The iRecovery Stick acquires data and recovers the deleted data from iPhone/iPad/iPod 

Touch devices. This section explains how to recover data from your iPhone/iPad/iPod 
Touch. 

 

Before the recovery process starts, do the following:  

1. Turn on the device. 

2. Ensure that the device battery is completely charged. 

3. Ensure that the proper drivers are installed on your computer. Their installation is 

performed automatically at the first iRecovery Stick connection.  

4. Connect the device to the computer with a data cable.  

5. Ensure that the device is unlocked. Please, note, iPhone 5s and newer devices 
have a fingerprint protection. 

6. If iTunes was installed you your computer before and you enabled the Encrypt 

iPhone/iPad/iPod Touch backup function for the device, you must set the Auto-

lock option to never or remove the password or remove the encryption and make 

a new iTunes backup before starting the recovery.  
 

NOTE: If you have iOS 7ï10 and newer versions, when you connect iPhone/iPad/iPod Touch device to a 
new computer, you will be asked to confirm that you trust the connected computer. To start recovering 
data, tap Trust in the appeared message on the connected device.  

 

To recover data from the iPhone/iPad/iPod Touch: 

 

1. Do one of the following: 

¶ Click Start Recovery on the Main page.  

¶ Click File > Start Recovery. 

¶ Press F5. 

2. Click the image of the device you want to scan. If multiple devices are connected 
to your computer, multiple images are displayed.  
NOTE: If your device does not appear in the list in several seconds after the connection, try to 

disconnect it and then connect back again. If you continue having problems, check your cable 
and make sure it is functioning properly. 

 



Parabenôs iRecovery Stick 

 

 11 

 

 

3. Select one of the following acquisition options and click the corresponding button 

to start acquisition: 

¶ Acquire textual and multimedia data: This type of acquisition allows 

acquiring graphics and multimedia along with the textual data.  

¶ Acquire all data including 3rd party Apps: This type of acquisition takes 

longer. Acquired data will contain not only text data and multimedia, but a 

full list of applications installed on the device, the list of their permissions, 

and data from most popular applications (Skype, Facebook, etc.).   
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4. The acquisition and recovery process starts. 
5. The details of the acquisition process are displayed in the Data Acquisition pane 

in the bottom of the screen. 
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Recovering Data from iTunes Backup Files 

 

The iRecovery Stick imports data from the iPhone backup files created by iTunes and 

recovers deleted data stored in them. If the iTunes backup files are encrypted (password 
protected), the password must be removed and a new backup created before recovery. 

To generate the backup file in iTunes 
 

¶ Right-click your iPhone device in iTunes under Devices and select Back Up. 

 

The default location for iTunes backup files is the as follows: 

 

¶ Windows XP: C:\Documents and Settings\USERNAME\Application Data\Apple 

Computer\MobileSync\Backup\<sequence of numbers and letters>\Manifest.plist 

¶ Windows Vista/7/8/8.1/10: C:\Users\USERNAME\AppData\Roaming\Apple 

Computer\MobileSync\Backup\<sequence of numbers and letters>\Manifest.plist 

 

To import the iTunes backup file into iRecovery Stick: 

1. Do one of the following: 

¶ Click File > Start Import. 

¶ On the Main page, click the Start Import from iTunes Backup icon. 

2. Navigate to the Manifest.plist file, and then click Open.  

3. If the backup is encrypted, remove the password and make a new backup. Note: 
Encrypted backups cannot be read without the password. 
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Working with Workspaces 

About Workspaces 

 

A workspace is a file with a .ds extension that contains information recovered from a 

single iPhone device.  

Creating New Workspace 

 

When you start data recovery, iRecovery Stick creates a new temporary workspace. The 
workspace is named Workspace<number>.ds. By default, the workspace is saved in the 
current Windows user folder. The workspace is also updated after you create a bookmark. 

You can change the default location where a workspace is saved, and you can use the 
Save As function to relocate and rename a saved workspace. 

 

To create a workspace: 

1. Start the data recovery process. See Recovering Data from iPhone. 

2. Click File > Save As, then click Save.  

To define the default workspace folder: 

1. Click Tools > Options, then type a new name and browse to the folder you want 

to use. 

2. Click Save. 

To change the name of a workspace: 

1. Open the workspace that you want to change. 

2. Click File > Save As. 

3. Browse to the location where you want to save the workspace, and then type a 

new name. 

Opening Existing Workspace 

 

Workspaces created by iRecovery Stick (*.ds files) can be opened from the user interface. 

1. To open an existing workspace, do one of the following: 

o On the Main page, click the Open Workspace button. 

o In the File menu, select the Open Workspace item.  

o Press Ctrl+O. 

 

When you open a new workspace, the currently open workspace closes. Unsaved 

information is lost. 
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Validating Workspace 

 

Through data validation you can check if the workspace data has been altered. This is 
valuable if the data you have collected will be used in court as evidence. 

 

To validate a workspace: 

1. Open an existing workspace with acquired data. 

2. In the main menu, select Tools > Validate Workspace or press CTRL+L. 

3. The data validation process starts. 

4. When the validation process finishes, you will see the message with validation 

results. 

Closing Workspace 

 

The workspace closes when any other workspace opens or iRecovery Stick shuts 
down. 
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Viewing iPhone Data 

 

The iRecovery Stick receives two types of data from the iPhone device or iPhone 
backup: 

 

¶ Recovered deleted data. 

¶ Other backup data. 
 

Recovered Deleted Data 

 

iRecovery Stick recovers the following types of data:  

 

¶ Contacts properties 

¶ Notes 

¶ Call History records 

¶ Contacts 

¶ Safari Bookmarks 

¶ Calendar records  

¶ Cell Locations 

¶ SMS 

¶ iMessages 

¶ Network connections (for iOS 4.x) 

 

To view the recovered data, select the Recovered Data category. 

The recovered data is parsed and displayed in grids.  

There is a separate tab for each category of the recovered data.  

The number of columns for each category depends on the category type.   

 

You can click [BINARY DATA] in the Raw Data column to view record contents in not 

parsed format in the File viewer to the right of the Data pane.  

 

If you want to view the data in another language, you may do so by selecting the code 
page after you open the record. There is an option in the drop down menu to select the 

different encoding options.  

 

To close the File viewer for the record, click Close.  
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Other Data 

 

Other data received from the iPhone backup includes the following parts: 

 

o Device properties: The properties of the iPhone from which data was recovered 
are displayed in the Properties tab of the Details pane. Click View Details to open 

the details pane. 

o Data categories: To the left of the Data page, the categories of the backup data 

are displayed. Click the category name to view its content. 

o Backup data: Acquired backup data is displayed in the right part of the Data page. 

Data representation depends on its format. 
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Text data includes the following categories: 

o Contacts: The device phonebook. 

o Messages: The device SMS messages. 

o Call History: The device call logs. 

o Organizer: The device calendar, memos, and so on. 

o Internet Data: Includes Safari suspend state, Safari Bookmarks, Safari History, 

Cookies, Delivery Accounts, Mail Accounts, and YouTube bookmarks. 

o Other Data: This data includes Properties, Maps Directions, Maps Bookmarks, 

Maps History, and Dynamic Text. 

 

Data from each category is displayed in a grid to the right of the Data page. There can be 

several tabs in the grid if data contains sub-categories, such as Calendar and Notes for 
the Organizer.  

 

Multimedia data includes Graphics and Multimedia category. 

 

This data is displayed as thumbnails. You can click a file to view it in a larger view. The 

image opens in the same pane. If necessary (for larger images), it scales to fit the window 
size. To return to thumbnails, click the scaled image.  

 

You can also use external viewers to view multimedia data. To open the image in the 

external viewer, right-click the image and select Open with. 
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Tracking History category includes information on geographical location of the iPhone 

user. It contains longitude and latitude coordinates along with a timestamp and is 

displayed in the Google Earth viewer. The location history information is determined by 
the cell-tower triangulation. 
 
NOTE: To view the location history, you should download and install the Google Earth Viewer.  

 

Tracking history is available for iPhone OS version 4.0 to 4.3.3. 
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Application data includes a full list of installed applications, parsed application data for 

the most popular applications, and the permission list, which includes the full list of 

permissions an application has and the application suspicion rate basing on its 
permissions. Data is displayed in three tabs: the first tab displays application 

permissions, the second tab includes the list of all installed applications, and the third 
tab displays the parsed application data in the tree-view structure.     

Application data for the following applications are currently parsed: Whisper, WhatsApp, 
Jott Messenger, KIK, LinkedIn, Gmail, Google Maps, Evernote, Mail.ru, TextFree, 

TextPlus, Vkontakte, Facebook, Facebook Messenger, Skype, Twitter, Chrome, 
VoiceMail. Dozens of file hiding apps are also supported. These apps are designed to 

hide photos and files behind a PIN or password. For most of these apps, the iRecovery 
Stick can display the hidden files. Some apps actually encrypt the files so the iRecovery 
Stick can only show that there are files and will allow you to export them but cannot 

open them. 
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